AERIE Team
http://forums.aerie.ru/

Не можете установить мод? ВАМ СЮДА!
http://forums.aerie.ru/viewtopic.php?f=17&t=2581
Страница 14 из 27

Автор:  Vit MG [ 11 фев 2009, 23:39 ]
Заголовок сообщения:  Re: Не можете установить мод? ВАМ СЮДА!

Все, я понял (нет, ты Aniko, не отвлекайся пока - разберись, пожалуйста, с чексуммами).

Мод ищет bif-файл ./DATA/AREA600A.BIF, а он у Aniko по адресу ./cd5/data/AREA600A.bif прописан - конечно, ничего не найдет! А сам файл нормальный - контрольная сумма правильная.
Обращаемся к инструкции Serdrick-а: http://aerie.ru/e107_plugins/faq/faq.php?view.9, раздел "Полная установка SOA+TOB."
Да, я помню, было сомнение в нужности пункта про перенос файлов из папок CD2-CD5 в папку Data. Пожалуйста, сомневаетесь - сохраните эти чудо-папки в архив (сотрёте потом), - но сделайте, как в инструкции, и baldur.ini отредактируйте, чтобы был только один вариант пути - основная папка игры для всех дисков.

Кстати, Aniko, сейчас в секции Alias файла baldur.ini что написано? Нужно разобраться.

Автор:  Aniko [ 11 фев 2009, 23:55 ]
Заголовок сообщения:  Re: Не можете установить мод? ВАМ СЮДА!

у меня все по инструкции Седрика сделано, это вообще самое первое с чем я начал знакомится при установке БГТ :)
И мувис-папки и дата-папки все вытащены из папок CD2...CD5 как в инструкции

[Alias]
HD0:=C:\BG12\BG2\
CD1:=C:\BG12\BG2\
CD2:=C:\BG12\BG2\
CD3:=C:\BG12\BG2\
CD4:=C:\BG12\BG2\
CD5:=C:\BG12\BG2\

Тут тоже все правильно. =)

Вытащил файл из СD5 и переместил в папка Data - мод установился без возмущений.

Автор:  Vit MG [ 12 фев 2009, 00:15 ]
Заголовок сообщения:  Re: Не можете установить мод? ВАМ СЮДА!

Aniko
Вот! То-то и оно, что не все скопировал из CD-папок (там еще, кроме этого AREA600A.BIF, точно, остались не скопированные файлы), а baldur.ini исправил - оттого и WeiDU не нашел этот bif: weidu проверяет все папки, что указаны в baldur.ini, а он уже "исправленный" - без CD-папок. (Спасибо, что написал, а то я удивился, почему weidu bif не нашёл.)

Еще раз проверь, Aniko: в соответствии с инструкцией Сердрика, скопируй из CD-папок все в основную папку игры. Перезапишутся - ничего страшного: качественные моды родные bif-ы не трогают - свои создают, если надо.
Чексуммы еще раз проверить (БГ2+ТОБ!) - и все, можно дальше на установку не пенять и не сомневаться.

Удачи!

Автор:  Aniko [ 12 фев 2009, 00:20 ]
Заголовок сообщения:  Re: Не можете установить мод? ВАМ СЮДА!

я конечно повытаскиваю все еще раз, ох, главное, чтобы не слетело....но вот еще одна проблема, уже с модом DrizztSaga

Цитата:
Choose your language:
0 [English]
1 [Italian]
2 [Spanish]
3 [Polish]
Using Language [English]
[English] has 1 top-level TRA files
[DRIZZTSAGA/Language/English/setup.tra] has 626 translation strings
SETUP-DARKRITUAL.TP2 2 0 Installed
SETUP-DARKRITUAL.TP2 2 3 Installed
SETUP-OVERSIGHT.TP2 6 1 Installed
SETUP-OVERSIGHT.TP2 6 2 Installed
SETUP-OVERSIGHT.TP2 6 3 Installed
SETUP-OVERSIGHT.TP2 6 5 Installed
SETUP-OVERSIGHT.TP2 6 7 Installed
SETUP-SOS.TP2 1 0 Installed
SETUP-CTB.TP2 1 0 Installed
SETUP-TS-BP.TP2 1 0 Installed
SETUP-ASCENSION.TP2 7 0 Installed
SETUP-BGT.TP2 8 0 Installed
SETUP-GUI.TP2 0 6 Installed
SETUP-BGTMUSIC.TP2 7 0 Installed
SETUP-DSOTSC.TP2 3 0 Installed
SETUP-NTOTSC.TP2 2 0 Installed
SETUP-BONEHILL.TP2 2 0 Installed
SETUP-BONEHILL.TP2 2 1 Installed
BIFF may be in hard-drive CD-path [C:\BG12\BG2\/MOVIES/25MOVIES.BIF]
[C:\BG12\BG2\/MOVIES/25MOVIES.BIF] 96891690 bytes, 6 files, 0 tilesets

Install Component [The Drizzt Saga for Tutu/BGT v1.0]?
[I]nstall, or [N]ot Install or [Q]uit?
Installing [The Drizzt Saga for Tutu/BGT v1.0]
Creating 1 directory
Copying 1 file ...
[chitin.key] loaded, 805161 bytes
Copied [chitin.key] to [DRIZZTSAGA/chitin.bak] (NO BACKUP MADE!)

BGT detected, proceeding with installation...
Copying and patching 1 file ...
[DRIZZTSAGA/misc/F_PATCH.2DA] loaded, 209 bytes

Updating worldmap with new areas...
Copying and patching 1 file ...
[DRIZZTSAGA/Worldmap/BGT/areas.tbl] loaded, 615 bytes
Copying and patching 1 file ...
[DRIZZTSAGA/Worldmap/BGT/links.tbl] loaded, 3330 bytes
Copying and patching 1 file ...
[DRIZZTSAGA/Worldmap/TRA/english/worldmap.tra] loaded, 149 bytes
Copying and patching 1 file ...
BIFF may be in hard-drive CD-path [C:\BG12\BG2\/DATA/SOS-RULE.BIF]
[C:\BG12\BG2\/DATA/SOS-RULE.BIF] 444857 bytes, 198 files, 0 tilesets
ERROR: illegal 8-byte read from offset 42928 of 42800-byte file WORLDMAP.WMP
ERROR: [WORLDMAP.WMP] -> [override] Patching Failed (COPY) (Failure("WORLDMAP.WMP: read out of bounds"))
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.

ERROR Installing [The Drizzt Saga for Tutu/BGT v1.0], rolling back to previous state
[DRIZZTSAGA/backup/0/UNSETSTR.0] SET_STRING uninstall info not found
Will uninstall 0 files for [DRIZZTSAGA/DRIZZTSAGA.TP2] component 0.
Uninstalled 0 files for [DRIZZTSAGA/DRIZZTSAGA.TP2] component 0.
SETUP-DARKRITUAL.TP2 2 0 Installed
SETUP-DARKRITUAL.TP2 2 3 Installed
SETUP-OVERSIGHT.TP2 6 1 Installed
SETUP-OVERSIGHT.TP2 6 2 Installed
SETUP-OVERSIGHT.TP2 6 3 Installed
SETUP-OVERSIGHT.TP2 6 5 Installed
SETUP-OVERSIGHT.TP2 6 7 Installed
SETUP-SOS.TP2 1 0 Installed
SETUP-CTB.TP2 1 0 Installed
SETUP-TS-BP.TP2 1 0 Installed
SETUP-ASCENSION.TP2 7 0 Installed
SETUP-BGT.TP2 8 0 Installed
SETUP-GUI.TP2 0 6 Installed
SETUP-BGTMUSIC.TP2 7 0 Installed
SETUP-DSOTSC.TP2 3 0 Installed
SETUP-NTOTSC.TP2 2 0 Installed
SETUP-BONEHILL.TP2 2 0 Installed
SETUP-BONEHILL.TP2 2 1 Installed
ERROR: Failure("WORLDMAP.WMP: read out of bounds")
PLEASE email the file SETUP-DRIZZTSAGA.DEBUG to flysoup, http://forums.blackwyrmlair.net/index.php?showforum=103
Using Language [English]
[English] has 1 top-level TRA files
[DRIZZTSAGA/Language/English/setup.tra] has 626 translation strings


Выбирал англ. язык, так как Fess выкладывал перевод. А там не создается отдельная графа, а просто файлы в папке english заменяются на русские.

Автор:  Vit MG [ 12 фев 2009, 00:42 ]
Заголовок сообщения:  Re: Не можете установить мод? ВАМ СЮДА!

Aniko писал(а):
PLEASE email the file SETUP-DRIZZTSAGA.DEBUG to flysoup, http://forums.blackwyrmlair.net/index.php?showforum=103
Сходил, почитал. Проблема известная - Леомар описал порядок установки: вот ссылка на сообщение.

Для лечения этой проблемы нужно прежде установить Drizzt Saga WM patch, а уж после Сагу Дриззита.

Автор:  Aniko [ 12 фев 2009, 01:07 ]
Заголовок сообщения:  Re: Не можете установить мод? ВАМ СЮДА!

Ничего не понимаю, все делаю как сказано, сначала патч, потом мод, когда мод вытаскиваю из архива, файлы не заменяю (хотя и с заменой тоже не ставится), потом заменяю файлы с русским переводом....

все равно ошибка эта...

Конечно там еще надо установить BG2 Fixpack перед всем этим, но я так понимаю и вообще перед установкой всех модов. Или все-таки установить и ничего не слетит? Если да, то какой именно?

Пробовал по-всякому, даже просто чистую англ. версию установить :(

Автор:  random [ 25 фев 2009, 19:17 ]
Заголовок сообщения:  Re: Не можете установить мод? ВАМ СЮДА!

Вопрос совсем идиотский - как и с помощью чего сделать из файла .tp2 файл .exe? Обяснения на сайте я не понял, каюсь, а без этого сверхсложного для меня действия многие моды не ставятся.

Автор:  Vit MG [ 25 фев 2009, 20:11 ]
Заголовок сообщения:  Re: Не можете установить мод? ВАМ СЮДА!

random писал(а):
как и с помощью чего сделать из файла .tp2 файл .exe?

Установка WeiDU-модов производится по инструкциям, прописанным в TP2-файле мода (его можно просмотреть обычным текстовым редактором). А исполняемым файлом - программой, которая собственно производит установку - является, переименованный в соответствии с именем tp2-файла, файл WeiDU.exe.
Часто архивы модов с целью экономии места исполняемый файл не включают.

Вот способ получить исполняемый файл мода:
1.) Скачайте актуальную версию WeiDU с сайта http://weidu.org (она будет упакована в архив)
2.) Разархивируйте в папку с игрой содержимое архива с актуальной версией WeiDU
3.) Сделайте копию файла weidu.exe и переименуйте эту копию по образцу [название tp2-файла мода].exe (квадратные скобки не нужны).
Готово.

А "делать из файла .tp2 файл .exe" совсем не надо.

Автор:  random [ 26 фев 2009, 13:24 ]
Заголовок сообщения:  Re: Не можете установить мод? ВАМ СЮДА!

Спасибо.

Автор:  karvel [ 11 апр 2009, 01:35 ]
Заголовок сообщения:  Re: Не можете установить мод? ВАМ СЮДА!

Всем доброго времени суток!
Возможно задам глупые вопросы, но облазил все фаги и не нашел никаких пояснений по таким моментам, связанным с установкой модов...

1. Часть модов, описанных на aerie, не понимаю, как скачать - ссылки на скачивания архива нет, есть только ссылка на "посмотреть базовый файл", где можно скачать его отдельные компоненты. К примеру - мод Mulgore and Xavia NPCs for BGT, описание коего находится здесь http://aerie.ru/mods.php?view.163. Что из списка скачивать и правильно ли это? И если скачивать, то по каким папкам сортировать?

2. Часть модов (как я понял, англоязычных разработчиков), при установке просит не указать цифрой язык установки, начать установку и т.д., а выводит кучу ключей (правда список их вроде бы одинаковый в разных модах), кои, как я понимаю, нужно набирать в командной строке. Честно говоря, достаточно сложно разбираться с тем, какие ключи нужны (их там несколько десятков). Может быть кто-то посоветует, какие из них требуются?

Заранее спасибо.

Автор:  Slinger [ 11 апр 2009, 14:32 ]
Заголовок сообщения:  Re: Не можете установить мод? ВАМ СЮДА!

1. ну просто в гугл вбиваешь Mulgore and Xavia. По первой ссылке и надо скачивать=).
2. давай конкретную проблему

Автор:  Резчица [ 22 апр 2009, 10:54 ]
Заголовок сообщения:  Re: Не можете установить мод? ВАМ СЮДА!

Не могу установить Торутед Сулс с русификацией. Из модов стоит Хлоя и Эдвин с Солафейном. Вот что пишет во время установки. Помогите!

Вложения:
Untitled-1.jpg
Untitled-1.jpg [ 72.33 КБ | Просмотров: 7222 ]

Автор:  Slinger [ 22 апр 2009, 18:55 ]
Заголовок сообщения:  Re: Не можете установить мод? ВАМ СЮДА!

ты бы сначала ставила TS-BP, а сверху уже Хлою и Солафейна

Автор:  Alina [ 22 апр 2009, 21:22 ]
Заголовок сообщения:  Re: Не можете установить мод? ВАМ СЮДА!

А Солафейн разве с ТС совместим? или это он с НеДжем несовместим? ???

Автор:  Slinger [ 23 апр 2009, 01:53 ]
Заголовок сообщения:  Re: Не можете установить мод? ВАМ СЮДА!

ну есть же TS, который 7.11, и TS-BP, который 6.10. Я так понимаю, это все-таки 6.10, который со всем должен быть совместим.

Страница 14 из 27 Часовой пояс: UTC + 3 часа
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/